Here you can give me feedback. Please report if something is wrong with a plugin!

 

Comments  

#11 Problem with GLIBCXX_3.4.21Luc 2017-06-29 16:20
Do you have a less bleeding edge version of these plugins? None of them works for me, in any DAW. Then I ran the standalone version and got this:

./Speaker_GodsCab: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./Speaker_GodsCab)

Upon inspection,

# strings /usr/lib/i386-linux-gnu/libstdc++.so.6.0.20 | grep GLIBC
(partially elided because the form won't let me post the entire output)
GLIBCXX_3.4.18
GLIBCXX_3.4.19
GLIBCXX_3.4.20
GLIBC_2.3
GLIBC_2.0
GLIBC_2.18
GLIBC_2.1
GLIBC_2.17
GLIBC_2.1.3
GLIBC_2.3.2
GLIBC_2.2
GLIBCXX_DEBUG_MESSAGE_LENGTH

I am running Debian Jessie. It's not that old a version, and I am not ready to upgrade. Do you REALLY need GLIBCXX_3.4.21 rather than GLIBCXX_3.4.20?
Quote
#12 RE: CommentsFlorian [Flo's Audio Plugins] 2017-06-30 10:33
Quoting Luc:
Do you have a less bleeding edge version of these plugins? None of them works for me, in any DAW. Then I ran the standalone version and got this:

./Speaker_GodsCab: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./Speaker_GodsCab)

Upon inspection,

# strings /usr/lib/i386-linux-gnu/libstdc++.so.6.0.20 | grep GLIBC
(partially elided because the form won't let me post the entire output)
GLIBCXX_3.4.18
GLIBCXX_3.4.19
GLIBCXX_3.4.20
GLIBC_2.3
GLIBC_2.0
GLIBC_2.18
GLIBC_2.1
GLIBC_2.17
GLIBC_2.1.3
GLIBC_2.3.2
GLIBC_2.2
GLIBCXX_DEBUG_MESSAGE_LENGTH

I am running Debian Jessie. It's not that old a version, and I am not ready to upgrade. Do you REALLY need GLIBCXX_3.4.21 rather than GLIBCXX_3.4.20?


Hello Luc,

this issue is caused by the GCC version I used for the compilation of the binaries (version 6), which tends to be incompatible with older systems / GCC versions.

I recompiled the latest version (should be released next month) with GCC 4.9 to avoid GLIBCXX_3.4.21; you can download the binaries here: https://s3.eu-central-1.amazonaws.com/audio-plugins/flos-audio-plugins_2017-6-30_gcc4.9.4.zip . I gave it a short test on a Debian Jessie, so they should work for you.

Thanks for bringing this up! There will be a source package for the next release, so people can compile it for their own system.

Thanks again and let me know if there's still an issue,
Florian
Quote
#13 SolvedLuc 2017-06-30 16:14
Yay! It works fine now. That was quick and kind. Many thanks!
Quote